0

Forum


You need to log in to create posts and topics.

QuickApp Pro ERROR : The NPM script 'start' exited without indicating that the Angular CLI was listening for requests

 I keep getting the error when I run the project on Visual Studio 2017
An unhandled exception occurred while processing the request.
AggregateException: One or more errors occurred. (One or more errors occurred. (The NPM script 'start' exited without indicating that the Angular CLI was listening for requests. The error output was: npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! quickapp-pro@2.1.0 start: `concurrently --kill-others "ng serve" "npm run theme" "--port" "57232"`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the quickapp-pro@2.1.0 start script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.
Attached is the error log. Any help is appreciated.
Uploaded files:

I have a same error with QuickApp.Pro. Has your problem been solved?

Hi. It’s a classic problem. Here’s how to fix it

1. Open a Powershell

2. Navigate to your ClientApp folder

3. Run “npm audit fix”

that should solve the issue

Had the same issues on QuickApp Standard. This is what I did following the above suggestion.

  1. Opened Command as Administrator (was getting permission issues)
  2. Navigated to your ClientApp folder
  3. Ran “npm install”
  4. Ran “npm audit fix” (found 1 high severity vulnerability)

that  solved my issue.



From now till 15th January, 2019. "QuickApp Standard" will be selling at a reduced prize of $10 Dismiss