You need to log in to create posts and topics.

"Cannot GET /"

Everything builds ok but when the browser launches I just get an error "Cannot GET /" when it tries to load http://localhost:21196/ Any ideas why?


open node.js command. change into the directory  ClientApp.

run ng serve --open

then you can see the problem.



UPDATE: Added attachment showing conflict in account.service.ts, at first glance everything seems legit, but still looking

Hey, I'm having the same issue and plan to jump into it shortly, but wanted to share the output you requested.

Node.js command prompt:

C:\Users\eric\source\repos\BlankCordovaApp1\QuickApp\Quick Application1\Quick_Application1\ClientApp>ng serve --open
Your global Angular CLI version (6.2.4) is greater than your local
version (6.0.8). The local Angular CLI version is used.

To disable this warning use "ng config -g cli.warnings.versionMismatch false".
** Angular Live Development Server is listening on localhost:4200, open your browser on http://localhost:4200/ **

Date: 2018-10-10T14:59:58.151Z
Hash: 22e30a55f1281add01ee
Time: 8600ms
chunk {main} main.js, main.js.map (main) 2.06 kB [initial] [rendered]
chunk {polyfills} polyfills.js, polyfills.js.map (polyfills) 746 bytes [initial] [rendered]
chunk {runtime} runtime.js, runtime.js.map (runtime) 5.22 kB [entry] [rendered]
chunk {scripts} scripts.js, scripts.js.map (scripts) 320 kB [rendered]
chunk {styles} styles.css, styles.css.map (styles) 293 kB [initial] [rendered]
chunk {vendor} vendor.js, vendor.js.map (vendor) 325 kB [initial] [rendered]

ERROR in src/app/services/account.service.ts(153,14): error TS2555: Expected at least 0 arguments, but got 2.
src/app/services/account.service.ts(155,31): error TS2339: Property 'id' does not exist on type '{}'.

i 「wdm」: Failed to compile.


Uploaded files:
  • 2018-10-10.png

Hello again. This worked for me although I don't know what impact it will have. If there's a better solution, I'd be interested.

I removed the second OperatorFunction parameter sent to .pipe

See here

updateRole(role: Role) {
if (role.id) {
return this.accountEndpoint.getUpdateRoleEndpoint(role, role.id).pipe(
tap(data => this.onRolesChanged([role], AccountService.roleModifiedOperation)));
else {
return this.accountEndpoint.getRoleByRoleNameEndpoint<Role>(role.name).pipe<Role>(
mergeMap(foundRole => {
role.id = foundRole.id;
return this.accountEndpoint.getUpdateRoleEndpoint(role, role.id)
//tap(data => this.onRolesChanged([role], AccountService.roleModifiedOperation)));

I have the same problem!

Quote from etichenor on October 10, 2018, 3:53 pm

Hello again. This worked for me although I don't know what impact it will have. If there's a better solution, I'd be interested.

return this.accountEndpoint.getRoleByRoleNameEndpoint<Role>(role.name).pipe<Role>(

The signature of the pipe "pipe<Role>" is incorrect. It should be: pipe<never, never>  or you can simply choose to make it implicit pipe.

So the line:

return this.accountEndpoint.getRoleByRoleNameEndpoint<Role>(role.name).pipe<Role>(


return this.accountEndpoint.getRoleByRoleNameEndpoint<Role>(role.name).pipe(

Updates in the typescript compiler checks for these rules. This has been updated in upcoming versions of QuickApp.


Eben Monney